Skip to main content
Advanced Search
Search Terms
Content Type

Exact Matches
Tag Searches
Date Options
Updated after
Updated before
Created after
Created before

Search Results

188 total results found

Data Viewer

Documentation on the Data Viewer

Developers

Documentation on setup, processes, APIs, etc.

DraMS

Dragonfly Mass Spectrometer specific topics

PACE/OCI

Ocean Color Instrument

XINA

699Wiki

The old wiki is now deprecated and all content has been ported here.

MOMA

Mars Organic Molecule Analyzer

User Guide

User Guide for the Data Viewer application. Each mission has their own version to document mission specific functionality.

GSE

Design

Design notes

Instructions

Various OCI instructions

OCI User Guide

Specifications

Roadmap

Getting Started

General XINA information and concepts.

API Reference

Lessons Learned

Utilities

Detailed information on XINA utility applications.

Task Management

Structured Data Standards

XINA standard data structures terms and organizing principles.

MOMA Data Viewer

PACE IandT

Glossary

This book is a dictionary of the terminology used by XINA and by specific missions supported by XINA.

MOMA Bibliography

OCI IandT

699

General 699 pages from the archived wiki.

SAM

SAM specific pages from the archive wiki.

OCI Step-by-step Instructions

User Guide

Step-by-step instructions to use the Data Viewer for various OCI tests

OCI Viewers

User Guide

Instructions on how to use the various OCI viewers

Overview

User Guide

The Data Viewer provides the following features: View data in real-time. Supports TCP or reading from a file. Load archives to post-process data. Supports CCSDS or 699 packets. Other formats can be easily supported. Generic displays (viewers) of telemetry dat...

Installation

User Guide

The Data Viewer is actively supported on Mac OS and Linux. Windows support can be provided if required. Mac OS Mac OS versions are distributed in dmg format. Contained within the dmg is a single .app which can be placed anywhere on your machine and then run. T...

Starting the app

User Guide

When first opening the application, you may be prompted with various dialogs, all of which can be closed. The main window of the application looks like If this window is closed, the whole application will be shut down. On some OSes, the menus will be accessib...

Design

GSE

Simulators Several applications have been created to simulate various parts of the system, and these simulators can be put together in various ways. Portions can even be swapped out for actual hardware when necessary. The major components (applications) are: ...

ADC Sweep

User Guide OCI Step-by-step Instructions

This page contains instructions on how to view the ADC Sweep data with the DDC Raw Viewer. The ADC sweep is performed by capturing multiple DDC raw captures while stepping the ADC sample point, which is a combination of the ADC mux delay (fine steps) and ADC C...

Touch Sensitivity Test

User Guide OCI Step-by-step Instructions

This page contains instructions on how to use the Data Viewer during the touch sensitivity tests. Setup Open 2 instances of the Stats Per Pixel vs. Time viewer. (or bring to front if already open) Set the Stats Mode on one to SD and the other to AVG. Note: Th...

ADC Output Phase Tuning

User Guide OCI Step-by-step Instructions

FEDS Client

Design

DDC Raw

User Guide OCI Viewers

The DDC Raw Viewer is used to display the DDC Raw captures. The DDC Raw captures are used for examining the raw samples out of the ADC. This mode is used for various tests: Line Tune Dark ADC Sample Point sweep RG Mag sweep RG Low sweep

Init Process

Design

RG Sweeps

User Guide OCI Step-by-step Instructions

These instructions are for the Rg Mag and Rg Low sweeps.

Tagging a Marker Interval as debug

Instructions

Go to oci.xina.io Open the "OCI Intervals" tool (Tools --> OCI Intervals) Change to the "Flight Model" (or the relevant model) Under the "Search Markers" panel on the left side, find the marker(s) you want to tag as debug For each marker, click the expand but...

Export Plot configuration: JSON Format

OCI User Guide

We use matplotlib v3.1.3 for our plot generation. The plot report is configured using JSON. The top level global applies global configuration. It currently supports a limited subset of the rcParams: font_size, font_family, agg_path_chunksize. Future versions w...

Filtering Data

OCI User Guide

Filter Expressions A filter expression is a Boolean Expression. A Boolean Expression can be any of the following: <Boolean Expression> AND <Boolean Expression> <Boolean Expression> OR <Boolean Expression> <Boolean Expression> XOR <Boolean Expression> N...

Filters

OCI User Guide

Mining all filter definitions are passsed to the oci_extract_hk_data, and it generates full/delta, time bin, and marker binned filtered data. The filtered data output files are associated with each filter definition ID This filtered data can be used to plot f...

View and download generated reports (aka packages)

OCI User Guide

Reports that have already been generated can be downloaded using the packages tool. You can download the report by clicking on the text in the label column. You can filter the packages using the top search bar. For example, in the below image we've filtered th...

Export process

OCI User Guide

The OCI housekeeping export process runs asynchronously on the OCI Run server. Requested data is extracted directly from the original time slice telemetry files using the same application from the realtime data mining process. In order to correctly interpret s...

Mnemonic Database

User Guide

When opening the application, the newest version of the mnemonic database is automatically loaded. You can manually load a different database with File --> Load database.

Export Data

User Guide

File --> Export HK Data... This will export ALL mnemonics for all cached data to your home directory. This feature has not been actively maintained and may not function as expected.

Quick Graph

User Guide

You can quickly graph telemetry data over time. Data Viewers --> Quick Graph